Beantwoord

BBOX3 router remote access op poort 8443 zetten

  • 26 February 2020
  • 35 reacties
  • 3794 Bekeken

Ik wil een HTTPS server in mijn lokaal netwerk bereiken vanaf Internet. 
Daarvoor heb ik port forwarding van poort 443 naar mijn lokale HTTPS server ingesteld.
Als ik mijn server oproep via een browser https://mynetwork/ , dan neemt de BBOX zelf de HTPPS call over. En de BBOX routeert die call naar https://mynetwork/7.3.8/gui/tpl/src/home/login.html .

Dit komt omdat de remote access configuratie op de BBOX ook op poort 443 is ingesteld.  Ik wil dus die remote access aanpassen, naar poort 8443. 
Maar de BBOX weigert die aanpassing, met een "submit error".

Ik ben ingelogd als user. Misschien moet ik ingelogd zijn als admin.
Maar ik ken het admin paswoord niet en kan dit dus niet proberen.

Wat kan ik nu doen?

 

mynetwork is het address van mijn BBOX router 

icon

Beste antwoord door Charlotte.D 2 March 2020, 16:44

Bekijk origineel

This topic has been closed for comments

35 reacties

Reputatie 7
Badge +4

Ik heb dit reeds gedaan @Martin , ik wacht samen met jullie mee op een verduidelijkend antwoord ;-) 

Je zou op de duur met een apart routertje moeten werken die je met zijn wan poort aansluit op de lan poort van de bbox en in deze router een tweede pppoe sessie opstart en en de bbox alleen gebruikt om tv decoders aan te sluiten en al de rest via deze router laat werken.

zie > Uw router gebruiken met router functionaliteit

Maar bij DynDns is toch maar een hulpmiddel om een veranderend Ip adres in de tijd op te vangen, en je blijft toch met portforwarding zitten.

Eigenlijk zoals het nu zit heb eigenlijk bijna geen dyndns nodig aangezien het wan ip adres niet meer zoals vroeger regelmatig veranderde.

Reputatie 6
Badge +3

Dat klopt. De hoofdbedoeling van de topic starter is om te kunnen verbinden met zijn https server. Het kan wel zijn dat wanneer je met DynDNS dat de port forwarding wel correct werkt. Dat kan ik niet met 100 % zekerheid zeggen. Aan een andere mogelijkheid kan ik niet meer bedenken buiten jouw voorstel.

Volgens mij heeft dit niks met instelling Dyndns te maken of die instelling al dan niet lukt voor RA port 8443, maar dcavey kan het altijd even uittesten, zo zijn we het dan met 100% zeker.

DynDNS is actief op de BBOX-3. Ik gebruik mijn persoonlijke DNS naam en mijn persoonlijk Comodo SSL certificaat (op mijn HTTPS server). Voor HTTP calls bereik ik mijn server wel. Dus de DynDNS setting werkt.

BBOX-3 heeft zelf een self-signed SSL certificaat geinstalleerd ( waar de browser me overigens voor waarschuwt, wegens not-secure). Maar dat is voor de portforwarding niet relevant. De BBOX probeert niet eens de call naar mijn  HTTPS server te forwarden. 

 

@Proximus Medewerkers , Kan er iemand op mijn vraag  hier antwoorden en eventueel doorsturen naar de specialisten ter zake. 

Reputatie 7
Badge +4

Misschien kan onderstaande voor de auteur “tijdelijk een uitweg bieden” ...

https://www.router-switch.com/faq/difference-between-https-port-443-and-8443.html

Port 8443 needs to add a port number during the visit, the equivalent of http 8080, not directly through the domain name, you need to add the port number. For example: https://domainname.com:8443.

 

 

Het probleem is dat je de RA poort niet kunt instellen in de bbox zijn GUI op poort 8443 !

Heb jij al eens geprobeerd of het bij u lukt .

NB: als er iets niet werkt bij portforwarding dan probeer ik altijd ook door de poort er eens toe te voegen in de URL link, om zeker te zijn dat het daarmee niks te maken heeft.

En zelfs de bbox eens heropstarten na invoeren van regels via de GUI heeft mij ook al soms geholpen .

Reputatie 7
Badge +4

@Martin RA 443->8443 ook niet mogelijk op mijn BBox3 Sagemv2 (error)

Dan zijn we toch al 100% zeker dat het met de Sagemcom bbox3 niet lukt, nu nog te weten komen of het ook zo is met de bbox’en van Tecnicolor, al heb ik de indruk dat proximus de bbox’en bij omruilen vervangt door die van sagemcom !

PS: louter als bijkomende info, nog iets teruggevonden van vroeger, jaren terug :

Portforwarding naar Lan Ip adressen instellen werkt.
Portforward naar de eigen gateway BBOX3 kan niet
(omtrent wel type BBOX3 het ging ?).
Dat wordt niet aanvaard door de webinterface die vast hangt
aan de poorten 443 en 8443 die in de GUI voorzien zijn .
Tenzij iemand de command set van de bbox3 kent om een ander
poortnummer te kiezen voor remote beheer is er geen andere oplossing

Als een nieuwe installatie gebeurt, krijgt de bbox een soort
voorlopig inlogid toegekend van het type sa123456.
Waarbij de benodigde poorten open staan.
En werkt het remote beheer dus even, pas na een tijdje wordt
de definitieve id toegekend type fd123456, maar dan zijn de poorten
voor remote beheer gesloten en kan je dus niet meer van buiten aan je bbox.
Je kan de poorten ook niet open zetten via de e-services
(nu MyProximus genoemd)
omdat je die nieuwe id niet kent, aangezien je daarvoor remote toegang nodig hebt,
dat dus niet meer werkt !.

ik heb dit bij mij eens geprobeerd en inderdaad ik krijg ook “fout bij opslaan” 

nu weet ik niet of het bij mij iets zou te maken hebben met het feit dat ik de gesloten poorten niet open gezet werden bij mij, maar bij u heb je ze al open gezet als ik het goed versta.

zie >

https://www.proximus.be/support/nl/id_sfaqr_ports_unblock_secu/particulieren/support/internet/veiligheid-en-bescherming/internetpoorten-en-beveiliging/internetpoorten-openen.html

Het gebruiken van een andere poort, bv https://mynetwork:60443 - zoals hierboven ook vermeld werd - is geen probleem. Het ziet er alleen wat stuntelig uit, als je een demo geeft. 

Mijn bedoeling was om extern poort 443 te gebruiken (zonder die dus expliciet te moeten opnemen in de URL) en dan binnen mijn netwerk - met een reverse proxy, zoals nginx - zelf verder de calls door te routen naar interne APIs.

Bij de volgende bbox3 firmware update zal de bug mss dan ook verdwenen zijn.

Reputatie 6
Badge +3

Ik heb ook de submit error. Dus lijkt mij eerder een bug te zijn.

je bent wel over een andere bbox bezig want https op enable zetten staat er niet.
Het is volgens mij gewoon een bug.
Bij u werkt dat dan wel op je bbox?

Reputatie 6
Badge +3

Ik heb mijn post ook aangepast, nadat ik het getest had. Op mijn Sagemcom B-Box 3,hardware version 2.1 krijg ik ook de submit error. 

Inderdaad ik had geantwoord op wat ik gelezen had in je voorlaatste post.

De vraag is nu of dit ook zo is bij de bbox3 van Technicolor 
Het is in ieder geval  bij de bbox3v+ ook het geval!

Dit zouden de proximus medewerkers in ieder geval al eens kunnen doorspelen aan de specialisten.

@dcavey kun je eventueel de rollen niet omkeren en aan je HTTPS server het poortadres 8443 toekennen 

Dat had ik ook eerst geprobeerd, op verschillende manieren.

  1. HTTPS/443 forwarden naar 8443 ==> Is niet toegestaan door BBOX. HTPPS/443 moet altijd naar internal port HTTPS/443.
  2. HTTPS service weglaten, dus alle TCP traffic voor 443 forwarden naar 8443 ==> De BBOX blijft de 443 traffic toch gewoon doorsturen naar de remote access URL (.../7.3.8/gui/tpl/src/home/login.html). Dit is blijkbaar de default 443 route. Dus mijn tweede route (443=>8443) wordt nooit uitgevoerd. De call komt dus niet tot bij mijn interne https server.

De enige opties, die aangeboden worden in de Access Control module, zijn afgeblokt :

  • Remote Access disablen ==> Submit Error
  • Remote Access poort op 8443 ==> Submit Error

Voor User zijn die functies niet mogelijk, (submit error). Voor Admin wellicht wel, maar ik ken het Admin paswoord niet. 

Ik zit vast ;-)

@dcavey  Proximus geeft nooit het wachtwoord van Expert en Admin door aan klanten , maar zij kunnen mss van op afstand eens proberen om in je bbox remote acces op poort 8443 te zetten.
Zelfs als ze een wachtwoord door geven aan een technieker die die nodig heeft om één of andere reden dan blijft dit wachtwoord maar een beperkte tijd geldig.

Kun je dan geen andere poort instellen op je sever ipv 8443, enfin ik ben maar aan het denken hoe je dit zou kunnen omzeilen.

Reputatie 4
Badge +1

Ik wil een HTTPS server in mijn lokaal netwerk bereiken vanaf Internet. 

Wat kan ik nu doen?

mynetwork is het address van mijn BBOX router 

Toch niet moeilijk:

Je moet gewoon een willekeurige externe poort forwarden naar interne poort 443 op het IP adres van je HTTPS server. bijvoorbeeld poort 60443

Dan is jouw HTTPS server vanuit het internet bereikbaar op https://mynetwork:60443

Dat is ook een stuk veiliger dan de default poort 443 te gebruiken.

 

Reputatie 4
Badge +1

 dit kunnen we dus vanop afstand niet, maar je kan poort 443 wel openen via My Proximus.

https://www.proximus.be/support/nl/id_sfaqr_ports_unblock_secu/particulieren/support/internet/veiligheid-en-bescherming/internetpoorten-en-beveiliging/internetpoorten-openen.html

Geert

Het “deblokkeren” van poorten 23, 80, 443 (“Lage beveiliging”) via My Proximus heeft hier niets mee te maken …

Daarmee worden geen instelling op de modem gewijzigd, en lost het probleem van de TS niet op :frowning2: .

Die eigen router lijkt me de enige overblijvende oplossing. Tenzij ik Proximus kan overhalen die Remote Access poort voor mij te wijzigen. Maar ik ben bang dat het lang duurt, voor ik daar bij de juiste Proximus persoon geraak. 

@dcavey Anders mss op één of ander proximus medewerker een privébericht sturen met de uitdrukkelijke vraag of zij de Remote Access poort op 8443 willen activeren in je bbox3 en ook een verwijzen plaatsen naar je topic hier 

https://nl.forum.proximus.be/internet-10/bbox3-router-remote-access-op-poort-8443-zetten-49688

zodat ze dit ook kunnen nalezen en zien dat het bij verschillende personen niet werkt net zoals bij mij o.a. op mijn bbox3v+ van sagemcom.

 

proxmus medewerkers zijn te herkennen hier op het forum aan het proximus symbool dat naast hun naam staat.

proximus symbool

dus waaraan je kunt zien dat er hier nog geen langsgekomen/geantwoord hebben :slight_smile:

NB: bv. GeertC  van proximus is hier bvb vandaag aanwezig op het forum.